Technical Specification and Requirements

Operation System and Accompanying Software

Wialon Local is an all-in-one solution installed from an ISO file that inludes:

  • base operating system Debian GNU/Linux 8 («Jessie») in form of an image netinstall (the missing files are installed from network package repositories);
  • additional software for proper functioning of the server (nginx, postfix, ntp, openssh, iptables, fail2ban and some other);
  • Wialon Local and its components.

Some OS components, hardware drivers and the modules of Wialon Local itself require network access during the installation process.

It is not recommended to install other software packages apart from the ones that are needed for proper operating of Wialon Local.

:!: ISO is developed for downloading and installing software in the BIOS mode. For UEFI, the installation should be carried out in the Legacy mode.

Server Requirements

Wialon Local can be installed and work only on a 64-bit operating system.

See below the minimum requirements to the server with the data storage for 2 years. These requirements were calculated on the basis of typical tasks solved by the servers and their configuration.

For a server with up to 100 units:

  1. CPU: Core i7;
  2. RAM: 16 GB (only Wialon);
  3. HD: soft-based RAID1 from 250 GB;
  4. Internet channel width (from the server): from 25 Mbit/s.

For a server with up to 4000 units and its own WebGIS:

  1. CPU: Xeon E31230 and higher;
  2. RAM: from 64 GB (Wialon + maps);
  3. HD: soft-based RAID10, 4×2 TB and more;
  4. Internet channel width (from server): from 50 Mbit/s.

For a server with up to 10000 units (the maximum number of units possible on one distribution):

  1. CPU: 2 up-to-date Xeon CPUs;
  2. RAM: from 128 GB;
  3. HD: software-based RAID10, 8×2 TB and more;
  4. Internet channel width (from server): from 100 Mbit/s.

:!: In some cases the automatic installation can be unavailiable.

You should understand that the above listed requirements are for guidance only and the selection of the hardware that Wialon Local is going to be installed on is particular and should, first of all, be based on the volume of the information you are planning to work with.

Node.js updating

In order for Wialon local version 1704 and above to function correctly, the Node.js 6.x package is required. Support for older versions of Node.js, starting with the release of 1804, will be discontinued.

The official Debian 8 and Debian 9 repositories include earlier versions of packages. When installing from our distribution package, the required Node.js version is installed automatically.

If you receive a notification that the version of Node.js that is used on your server is out of date, you can update it manually.

To do this, log in to the terminal on behalf of the main user (root) and run the following commands:

cd /home/wialon/wlocal/
service wlocal stop
./adf_script stop
apt-get install -y curl
curl -sL https://deb.nodesource.com/setup_6.x | bash -
apt-get install -y nodejs
npm -g install forever
npm install
chown -R wialon:wialon /home/wialon/
service wlocal restart

Check the availability of your sites after they restart. To update Node.js, you can also contact technical support. In this case, in the letter specify SSH credentials (IP, login and password) to access the server console. The instruction is also located on the official site of the Node.js developer.

:!: Installing an update from version 1704 to 1804 is not possible without updating NodeJS.

Was this helpful?
Thank you!